Page 1 of 1

Controllino MAXI not recognized

Posted: Tue Mar 17, 2020 9:09 am
by JOEG
Hello,
I have two Controllino MAXI's. I've used them both and they are functional.
I'm trying to upload the same code to both of them.
When I connect the USB to MAXI #1 it works and the code it uploaded.
I then unplug the USB from MAXI #1 and plug it into MAXI #2, but the PC doesn't recognize it.

MAXI #1
Device Manager shows:
Arduino Mega 2560 (COM6)

Arduino IDE:
Recognizes COM6 and uploads correctly.

MAXI #2
Device Manager shows:
Arduino Mega 2560 (COM3), Even though it is connected to the same port.

Arduino IDE:
Does NOT recognize COM6 and doesn't upload. I tried uploading to COM3 but that also doesn't work.



What can I do?

Re: Controllino MAXI not recognized

Posted: Sun Mar 22, 2020 3:01 am
by r_merc
I have a similar set up and one Maxi is com 4 and the other is com 3. Sounds like what you are doing is correct.

Re: Controllino MAXI not recognized

Posted: Sun Mar 22, 2020 3:01 am
by r_merc
I have a similar set up and one Maxi is com 4 and the other is com 3. Sounds like what you are doing is correct.

Re: Controllino MAXI not recognized

Posted: Mon Apr 27, 2020 9:35 am
by Jarda
Hello,
every CONTROLLINO has usually different COM port.

Because typically each new device is assigned with a new COM port number. To be precise - this may be configured in the operating system settings - if a new device with the same PID/VID gets the same or a new COM port number.

Please also try to manually change the COM port in the computer manager, COM3 can have collision.

Regards
Jaroslav